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ABSTRACT
A new methodology for interactive design of turbomachinery blades

is presented. Software implementation of the methods provides a user

interface that is intuitive to aero-designers while operating with stan-

dardized geometric forms. The primary contribution is that blade sec-

tions may be defined with respect to general surfaces of revolution

which may be defined to represent the path of fluid flow through the

turbomachine. The completed blade design is represented as a non-uni-

form rational B-spline (NURBS) surface and is written to a standard

IGES file which is portable to most design, analysis, and manufactur-

ing applications.

INTRODUCTION

A wide variety of machines with rotating components incorporate

blades for imparting energy to, or extracting it from, various fluid

streams. Examples include turbines, pumps, compressors, fans, propel-

lers, etc. In all of these applications, the blade design is critical for

achieving optimal overall performance. Since the underlying function

of a blade is to smoothly change the velocity of fluid flow, they are gen-

erally comprised of parametric sculptured surface models. The complex

interaction between the fluid mechanics (i.e., machine performance) and

the blade geometry is of fundamental importance in blade design.

Motivation

Experienced blade designers use specialized skills to determine opti-

mal blade geometries. Blade designers represent the blade geometry as

a grid of points on the surface of the blade (Figure 1) or with non-stan-

dard algebraic equations (Crouse, 1981). In order to manufacture the

blade using contemporary computer-aided manufacturing technology it

must be represented in a portable format. For this reason the blade is

typically regenerated using a CAD package based on point data or

other primitive input. However, this procedure can lead to misinterpre-

tation of the data by the CAD operator, who essentially remodels the

blade. Ultimately, errors may be introduced and the original intended

performance is sacrificed.

Axial blade design typically begins with two-dimensional stream

line curvature through-flow algorithms that aid in determining the

blade cross-section geometry from aerodynamic requirements (Law

and Puterbaugh, 1982; Crouse, 1981). Input to these programs includes

overall aerodynamic performance and basic blade section information.

Output is generally a grid of points on the blade surface. The restric-

tions of these programs are that they will only generate certain types of

blade geometry (i.e., axial compressor blades). Casey (1982) describes

typical design methodology for centrifugal (radial-flow) blade designs.
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Figure 1. Blade as three-dimensional grid of points



Blades are typically defined by a series of cross-sectional profiles

stacked at several radial locations. The profiles (or blade sections) are

generally developed on planes, or on concentric cylinders or cones,

which are intended to approximate the path of the fluid flow through

the turbomachine. The blade sections are related to these surfaces and

to one another by a stacking axis, which is generally limited to a line

segment.

However, the stream curves generated from stream-line curvature

through-flow algorithms are a more precise representation of the actual

axial path of the fluid flow. By revolving these curves about the

machine axis, general surfaces of revolution can be generated that

exactly represent the radial boundaries of the fluid flow (i.e., hub and

casing) as well as providing a more accurate representation of the inter-

nal paths than cylinders or cones. Throughout this paper these surfaces

of revolution are referred to as stream surfaces because they are gener-

ated from two-dimensional stream curves. Thus, the stream surfaces

better approximate the actual three-dimensional fluid behavior.

This paper introduces a method of designing blades that is interac-

five, allows for blade section development using general stream sur-

faces and stacking axes, and provides an interface and design

methodology familiar to the aero-designer. All the available inputs are

geometric by nature but are represented as familiar aerodynamic

parameters. Any preprocessing, separate analysis, or designer experi-

ence is easily communicated to the blade model through a robust inter-
face. General stream surfaces are used to allow for more accurate and

advanced designs. A simple interactive method allows for stream sur-

face generation and editing. Also the stream curves can be read in from

a file to allow for compatibility with existing flow analysis codes.

A transformation is developed which allows construction of, and

interaction with, two-dimensional blade sections which are simulta-

neously mapped onto corresponding stream surfaces. Thus, changes of

these basic planar curves results in immediate changes to the three-

dimensional blade model. Allowing the stacking axis to be a general

space curve facilitates very flexible twist and lean capabilities. Ulti-

mately, a robust and transportable surface model is produced. The

blade is represented as a non-uniform rational B-spline surface

(NURBS) (Piegl, 1991) and the final output is a standard IGES (Initial

Graphics Exchange Specification) file (NIST, 1990). The blade surface

geometry can then be analyzed by existing computational fluid dynam-

ics packages.

Calculation of the interaction between the fluid flow and the blade is

a complex and time consuming problem. When a blade geometry is

decided upon, it must go through extensive computer simulations to

determine the flow characteristics produced as a result of the interac-

tion of blade and fluid (Chima and Yokota, 1990; Mokhtar and Oliver

1994). Almost always, the desired flow, and hence machine perfor-

mance, is not what the designer intended. The blade geometry must be

changed and the whole process repeated, perhaps several times. Most

CAD systems are designed for general purpose surface modeling and

allow shape change via direct geometric manipulation such as control

point modification. Since shape change based on blade parameters such

as inlet and exit angles, chord, thickness distribution, etc., are not gen-

erally supported in commercial CAD systems, changing blade geome-

try can be a difficult and time consuming process. This paper

introduces an efficient methodology for creating a blade from scratch

and subsequently modifying its design. A simple tug with the mouse on

a stream curve or an alpha-numerical entry of a section profile's thick-

hess results in changes to the three-dimensional model. The modified

blade is ready for analysis in a matter of minutes.

l"erminoloav

A clear understanding of some basic concepts of blade design is para-

mount to understanding the need for, and the usefulness of this work. A

blade is represented in a cylindrical coordinate system comprised of r-,

z-, and 0-coordinates (Figure 2). The blade is oriented such that it

revolves about the z-axis in the 0-direction. For axial turbomachinery

components, the r-axis is referred to as the blade span direction, and the

z-axis is referred to as the chord direction. In an axial flow turboma-

chine, fluid flows past the blade in the positive z-direction. The axial

path of fluid flow can be represented as a stream curve in the r-z plane.
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Figure 2. Blade in r-z-O space

Typically, several stream curves are required to define a blade. Fig-
ure 3 shows two such stream curves and one stream surface for both

axial and radial blade design applications. The picture on the left-hand

side of Figure 3 shows two stream curves and the picture on the right
shows the lower stream curve revolved about the z-axis to define a

stream surface. The stream surface is a three-dimensional representa-

tion of the flow field.

A blade model is generated from several blade section curves which

are each related to a specific stream surface by the stacking axis (Figure

4). A stream surface characterizes the desired axial fluid flow through

the machine and is defined by a stream curve in the r-z plane.

The blade itself consists of "stacked" cross-sections or blade sec-

tions. As shown in Figure 5, the mean camber curve is the "skeleton" of

the blade section, and points on the section are generated by offsetting

mean camber curve points along corresponding normals by t/2 and 4/2,
where t is the thickness of the blade.

The blade sections are fixed in the r-z-O space with reference to a

stacking axis. The surface definition of the blade is obtained by lofting

the blade sections as shown in Figure 2 (Piegl, 1991).
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Figure 3. Top: axial stream curves, axial stream surface;

Bottom: radial stream curves, radial stream surface

BLADE DESIGN METHODOLOGY

BladeCAD introduces a new design methodology which is motivated

by the need to define and modify blade sections within general surfaces

of revolution, while providing intuitive interaction techniques. Direct

definition and modification of a three-dimensional space curve, which

characterizes both the shape of the blade section and the stream surface,

would be extremely difficult. Furthermore, blade designers are accus-

tomed to interacting with blade sections using normalized two-dimen-

sional coordinates. The goal of this work is to provide familiar two-

t _ stacking point

) _ stacking axis

l

Figure 4. Stacking axis and stream curve

dimensional shape construction tools that allow definition and modifi-

cation of blade sections precisely within general surfaces of revolution.

tO
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m

Figure 5. Blade section on mean camber normals

Coordinate Transformation

The stream curve, being a general plane curve, can be characterized

by its arc length. The differential arc length dm is defined by,

dm= _/(dr) 2+ (dz) 2 (1)

Figure 6 shows the m-direction on the stream surface. Since the stream

curve is defined parametrically as a NURBS curve (i.e., r(u), z(u)) inte-

grating both sides of Eq. (1) results in,

u

m = _,J(ru(U))2+ (Zu(U))2du (2)
o

where ru(u) and zu(u) are the derivatives of r(u) and z(u) with respect to

u, respectively.

The tO-coordinate is difficult to interpret intuitively, so the m and r0-

coordinates are normalized with respect to radius. The normalized dif-

ferential arc length din" is defined by,

din' - dm (3)
t"

Again using parametric representation and integrating yields,

u

o

These relationships provide a transformation between a surface of

revolution defined in cylindrical coordinates (r, z, 0) and equivalent

two-dimensional spaces (m, to) and (m', 0). The relationship between

the (r, z, 0) and (m', 0) spaces is angle preserving and is useful for defi-

nition of critical blade angle properties. The relationship between (r, z,

0) and (m, r0) is length preserving and is necessary for construction of

blade section profiles.
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m-direction

Figure 6. m- and tO-directions on stream surface

The above equations are computationally expensive and therefore do
not allow for real-time coordinate transformations. When the stream

curve is defined, Eqs. (2) and (4) are used to find the corresponding m

and m'-coordinates. The m and m'-coordinates are interpolated with the

same parameterization as the corresponding stream curve, and the

result is stored as a five-dimensional cubic B-spline (i.e., r, z, 0, m, m').

Once the B-spline is created, converting from one coordinate to another

is a simple inverse problem with a Newton-Raphson search for the

parameter u. Evaluating the B-spline at the parameter u yields the r, z,

0, m, and m'-coordinates.

Stream Surface and Stackin 9 Axis

BladeCAD accepts any general NURBS curve for stream curve and

stacking axis definition. The only requirement is that the stacking axis

intersect all stream surfaces. This intersection is called the stacking

point (Figure 4). In practice stream curves may be read in from IGES

files generated from previous flow analyses. Alternatively they may be

created interactively by selecting points in the r-z plane which are inter-

polated with a cubic NURBS curve. Similarly, the stacking axis may be

read from an IGES file or created interactively.

Mean Camber Construction

In a two-dimensional space defined by m" and O, a mean camber

curve is defined by the inlet angle (txi), exit angle (%), stagger angle

(7), and the chord (C') as shown in Figure 7. This information is used to

represent the mean camber curve as a cubic Bezier curve (i.e., a single

segment cubic B-spline). The mean camber curve can be considered the

"skeleton" of the blade section. The shape of the mean camber curve

(i.e., the incremental distribution of its tangents) is specified in the two-

dimensional m'-0 space because this space is angle preserving with

respect to r-z-O space. The transformation preserves angles because

both length components are normalized with respect to radius, i.e,

rdO dO dO
tanct -dm - dm/r - din' (5)

The three angles described above are one method traditionally used

to fully describe the mean camber curve (Crouse, 1981) Another

method involves specifying the desired angle distribution (metal angle)

and then integrating it to obtain points on the mean camber which may

then be interpolated with a cubic NURBS curve. Of course, this method

introduces some physical constraints on the metal angle curve, i.e., it

can not have vertical segments. Once the mean camber is constructed in

m "-0 space it is converted to m-r0 space so that thickness values may

be applied in a length preserving space.

0
m"

Figure 7. Mean camber definition

Blade Section Construction

The blade section is comprised of a suction side curve, and a pres-

sure side curve (Figure 9). The suction and pressure side curves are

computed by interpolating points offset along mean camber curve nor-

mals by +_t/2, where t is the thickness of the blade.

The thickness (t) is defined by the following input data: chord-nor-

malized leading edge (tlJC), trailing edge (ttelC), and maximum (tmax/

C) thickness, and their corresponding locations (sle, ste, Smax) relative to

mean camber curve arc length. Figure 8 and Figure 9 show how these

parameters relate to the thickness function and how they apply to the

associated mean camber curve. The thickness function curve is a com-

bination of three splines: a cubic natural spline (US Navy, 1993) that

interpolates the three data points, and two ellipses at either end (Figure

8). The thickness function has vertical tangents at both ends. This pro-

duces suction and pressure side curves with tangent continuity at their

endpoints (Farin, 1988). A joining procedure redefines the suction and

pressure side curves as one NURBS curve (Piegl and Tiller, 1995)

t Ic
thickness function

(s.,o_,,t,._lC) (Ste,t,dC)

°7o arc

Figure 8. Thickness function
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Figure 9. Thickness definitions on mean camber

Mappin_q Blade Section to r-z-O SPace

After a blade section is constructed in m-r0 space it is converted to

its corresponding stream surface in r-z-O space via the inverse mapping

procedure mentioned above. Thus when the blade section is defined in

the two-dimensional m-r0 space, there is an exact r-z-O equivalent

blade section that lies directly on the stream surface (Figure 10).

Figure 10. Blade section conforming to stream surface

IMPLEMENTATION

BladeCAD is implemented in an interactive, user-friendly software

application. User interface functionality is supported by OSF/Motif

(Young, 1992) and Silicon Graphics Open Inventor TM (Wernecke,

1994) is used for graphical display and interaction. The following sec-

tions describe the interface components and their functionality.

Main View

The Main View window (Figure 11) has a menu bar with the stan-

dard File, Edit, and View menus. The File menu contains buttons

labeled New Section, Open, Save, and Quit. This window displays the

assembled blade in a three dimensional space defined by an r-z-O coor-

dinate system. The stream curves and the stacking axis are also dis-

played.

Under the File menu is a button labeled New Section. When pressed,

this will prompt the user with an input box asking for the radius of the

new stream curve. The new default stream curve will be a cubic B-

spline with co-linear control points. The user has the option under the

Edit menu to drag the control points of any one of the stream curves or

the stacking axis in the r-z plane. This will result in a real-time update

of the entire blade geometry. It is also possible to drag the stacking axis

in the r-0 plane. The View menu has various viewing options such as

displaying the stream surfaces or resetting to the home orientation. The

home orientation is the initial position of the geometry in the window.

The user may use the mouse to zoom, translate and rotate. Selecting the

home orientation option labeled Reset will return the window to the ini-

tial view.

Figure 11. Main View

Inout Panel

The Input Panel (Figure 12) has a Section menu at the top (upper left

of Figure 12). This menu has a button to select each section used for the

design of the blade. The user can add sections by picking New Section

under the File menu in the Main View. The Input Panel's Section menu

will add a new button accordingly.

While some editing procedures affect the entire blade, most features

of BladeCAD allow changes to only one section at a time. The Section

menu allows the user to choose the current blade section. Below the

menu bar is an area for entering the thickness function parameters, the

mean camber angles, i.e., inlet, exit, and stagger angles ((zi, %, and y),

and the solidity ((_), chord (C), and number of blades (NB).

The bottom of the Input Panel has an Quit, Undo, and Cancel button.

The Undo button will revert the blade parameters back to the previous

ones in memory. The Cancel button will ignore any new parameters

typed in and return the values displayed to the current parameter values

in memory.

3.3 Thickness Function Editor

The Thickness Function Editor (Figure 13) permits the user to

change the thickness function parameters via interaction with the

mouse. This window displays the same curve shown in Figure 8. The

Thickness Function Editor has a menu bar with an Edit and View menu.
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The Edit menu allows the user to toggle the editing capabilities. There

are nine control points (shown as white spheres), as well as the thick-

ness function parameters represented as interpolated data points

(shown as black spheres). The control points can be dragged with the

mouse. When a control point is moved the thickness function is re-eval-

uated with the resulting new set of control points.

the Section menu in the Input Panel). This is one example of the flexi-

bility of BladeCAD, the information can be entered in several ways and

all related displays are updated automatically. The kiew menu allows

the user to resize the control points and reset the display to the home

orientation.

t/C

%arc

i m

Figure 13. Thickness Function Editor

Section Editor

The Section Editor (Figure 14) has a menu bar with an Edit and View

menu. The Edit menu allows the user to toggle between editing the

mean camber as a cubic NURBS curve or as a circular arc. Using a cir-

cular arc for the mean camber geometry is a standard method employed

by blade designers. Three points are required to define a circular arc.

The first point is fixed at the origin. The user can drag the second or

third point with the mouse. The inlet angle (cq), exit angle (¢te), and

stagger angle (7) (Figure 7), as well as the chord (C) and solidity (a) are

automatically updated.

Figure 12. The Input Panel

Alternatively, when one of the three thickness function parameters is

moved all three are re-interpolated to make a new thickness function

and the corresponding text input fields in the Input Panel change to dis-

play the new values. Alternatively, the thickness function parameters

may be changed alpha-numerically on the Input Panel (Figure 12) and

the view is updated. The blade geometry in the Main View changes

accordingly, depending on which blade section is being edited (recall

Figure 14. Section Editor



The cubic NURBS mean camber curve is defined by two end points

and two end tangent vectors. This information comes from the three

angles: inlet (cti), exit (%), and stagger (_/). When editing as a NURBS

curve, the user can drag the mean camber curve control points directly.

When a control point is moved the mean camber curve is re-evaluated

with the resulting new set of control points. The user can undo any

changes to the control points and start again with the mean camber

defined from the angles in memory. The View menu allows the user to

resize the control points, reset to the home orientation, and hide or

show the control points.

Blade Metal Angle Editor

The Blade Metal Angle Editor (Figure 15) displays the blade metal

angle curve and has a menu bar with an Edit and View menu. The blade

metal angle curve is the arc tangent of the derivative of the mean cam-

ber curve's 0-coordinate with respect to the m'-coordinate (atan(dO/

dm ") vs. m "), essentially a plot of the angle distribution along the mean

camber. The Edit menu has a toggle for two edit modes, editing the

blade metal angle curve as a NURBS curve or as a straight line.

Figure 16 shows an AST fan blade row. Thus far in this paper only

axial blades (like Figure 16) have been shown. However, the applica-

tion is not limited to this type of blade design.

Figure 15. Blade Metal Angle Editor

The first editing option is to edit the blade metal angle curve as a

NURBS curve. The user drags one of the control points and the curve

changes accordingly. Then the blade metal angle curve is integrated to

generate a new mean camber. The corresponding modified mean cam-

ber curve is then drawn in the Section Editor. This happens in real time.

The second editing option is to edit the blade metal angle curve as a

line. When this option is chosen the end points of the previous NURBS

curve are connected with a straight line. The line is modified by drag-

ging one of the end points and any modifications automatically update

the shape of the mean camber. The integral of a straight line is a circu-

lar arc. This is a second method of editing the mean camber as a circu-

lar arc. As before, the View menu allows the user to resize the control

points and to reset to the home orientation just as in the other windows.

EXAMPLE DESIGN PROBLEM

The following examples are presented to demonstrate the robust

capabilities of BladeCAD. The examples include a new AST fan blade

design, a centrifugal compressor and an axial inducer pump.

Figure 16. AST fan blade

The radial blades shown in Figure 17 are a good representation of the

generality of BladeCAD. The same overall design methodology used to

produce axial fan blade in Figure 16 was used to create the radial blade

shown in Figure 17.

Figure 17. Centrifugal compressor
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Figure 18 shows an axial inducer pump blade row. The inducer pump

blade is an example of another class of blades that can be easily mod-
eled with BladeCAD.

Figure 18. Axial inducer pump

CONCLUSIONS

BladeCAD offers easy creation and modification of blade geometric

models using familiar blade design parameters and methodologies.

Giving the blade designer the capability of fully representing the blade

geometry in the portable IGES format from BladeCAD eliminates the

previous necessity of having a CAD operator interpret the designer's

point data to model the blade in a general CAD package, and also elim-

inates any related errors. The manual iteration process of designing a

blade, testing it for flow characteristics, and making modifications

accordingly is still basically the same. However, the modifications can

bc made quickly and easily in an environment that offers parameters

familiar to the blade designer while producing a precise and portable

NURBS surface model. The general sa'eam surface capabilities enhance

existing blade design technology by allowing the designer to better

approximate the desired flow field.

BladeCAD is not limited to axial turbomachinery components.

Radial flow turbomachinery components such as impellers are

designed with the exact procedures mentioned for axial flow turboma-

chinery components. The application is general enough to design all

types of turbomachinery blades.
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