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Abstract 

The Imaging for Hypersonic Experimental Aeroheating Testing (IHEAT) v4.0 thermography 
data processing code obtains global heat transfer information from wind tunnel models tested in 
the NASA Langley Aerothermodynamics Laboratory (LAL) facilities. This user manual describes 
the purpose and the features of IHEAT. A tutorial and a flow chart are included that describe the 
tools and detail the procedural steps of the phosphor thermography data reduction process 
implemented in IHEAT v4.0.  
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The IHEAT v4.0 software is a data reduction code for global thermography data acquired in 
the NASA Langley Aerothermodynamics Laboratory (LAL) hypersonic wind tunnels. IHEAT uses 
red and green color-intensity data from two-dimensional images of wind tunnel models to compute 
temperatures and heat-transfer rates using a semi-infinite, one-dimensional heat transfer 
approximation at each image pixel. Multiple automated tools in IHEAT v4.0 decrease the time 
required to reduce the data from a phosphor thermography wind tunnel run. Data at one or all of 
the image pixel locations can be exported to computer files for further analysis. 

The prior version of IHEAT, v3.2, was written in PV-WAVE® (now owned by Rogue Wave® 
Software) in 1994 and was limited in functionality to fit within the memory constraints of the 
available computers at the time. IHEAT v4.0 is written in MATLAB® by MathWorks® and contains 
several new features that leverage the increase in available memory of the current computers. A 
Piecewise tool permits the user to extract data along a segmented line cut that can follow interesting 
features in the image better than the single, straight line cuts that were possible with the legacy 
Length and Profile tools. The new Load Run and Batch tools facilitate batch processing by loading 
in all of the input files and images for a run at the same time. Load Run permits the user to process 
the available run images manually, while Batch automatically saves heat transfer data from all of 
the images based on the analysis previously performed on a single frame. IHEAT v4.0 also can 
automatically calculate the temporal collapse of reference line cuts from the time history heating 
data for a run to indicate the appropriate frame to reduce for each run. 

The IHEAT v4.0 source code was compiled into a standalone executable file that can be 
accessed remotely from several computers with different operating systems, simultaneously. The 
software is run through the MATLAB® Compiler Runtime engine, and therefore, IHEAT does not 
require a software license to run. Any software commands executed in the IHEAT v4.0 code will 
not affect other similar applications running on the same machine. Similarly, changes to the parent 

software do not affect a compiled code. These features of IHEAT v4.0 are improvements over the 
legacy v3.2 code, which required regular maintenance to avoid losing functionality as the PV-
WAVE® programming language was upgraded.  
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References 1, 2 and 3 describe the phosphor thermography data acquisition and reduction 
process used during aeroheating tests in the LAL hypersonic wind tunnel facilities. During a 
phosphor thermography wind tunnel run, the phosphor coating on a ceramic model fluoresces 
when the coating is illuminated by ultraviolet lights. A digital 3-color (red, green, and blue) Charge 
Coupled Device (3-CCD) camera is used to take pictures of the model and these images are loaded 
into IHEAT v4.0 for analysis. Red and green intensity values at each pixel are used to calculate the 
model’s surface temperature at a given instant in time. Temperature contours are displayed in the 
IHEAT v4.0 window with a representative color map. Heat transfer coefficients are then computed 
at each pixel for a given time, based upon prerun and run-time images, using the approximations 
listed in references 1–3. These heat transfer coefficients are displayed either as dimensional values 
or nondimensionalized with respect to the Fay-Riddell stagnation heat transfer coefficient for a 
user-specified hemispherical nose radius. 

Section 3 of this user manual is comprised of an overview of the IHEAT v4.0 tools, followed 
by three subsections that describe how IHEAT v4.0 is used to reduce the LAL phosphor 
thermography data. The tutorial in section 3.2 offers a brief description of each of the tools 
included in IHEAT v4.0. The flow chart in section 3.3 provides a step-by-step explanation of how 
aeroheating data can be reduced following a wind tunnel run in the LAL facilities. References 4 
and 5 (which are internal reports) explain the phosphor thermography data acquisition and 
reduction processes in more detail. Subsection 3.4 and section 4 discuss best practices for reducing 
phosphor thermography data. Finally, section 5 describes planned modifications to IHEAT v4.0 
that will be included in future releases of the software. 
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IHEAT v4.0 runs on a LINUX operating system and is accessible remotely from Windows, 
Linux or Macintosh operating systems. Several tools are available in IHEAT v4.0 to reduce data 
obtained during phosphor thermography tests. These tools (typeset in italics) are grouped 
according to their primary functions and described briefly in section 3.1. A detailed tutorial in 
section 3.2 explains the use of each of these IHEAT v4.0 tools with images of the IHEAT graphical 
user interfaces (GUIs) as the different steps are performed. Several paths are available to process 
data from a phosphor thermography run in IHEAT v4.0; however, a typical data reduction process 
is demonstrated in the flow chart in section 3.3. Instructions for accessing the IHEAT v4.0 software 
are provided in the first two pages of the flow chart. Section 3.4 provides guidelines to avoid 
problems with running IHEAT v4.0 incorrectly that were discovered during beta testing. 

3.1. Overview of IHEAT v4.0 Tools 

The most relevant tools in IHEAT v4.0 are briefly introduced in this section of the user manual. 
These tools and others are described in more detail in the tutorial and flow chart in subsequent 
sections. 

 
Data from wind tunnel runs conducted in the LAL facilities prior to 2015 and originally 

processed using the older version of IHEAT can be re-reduced in IHEAT v4.0, as necessary. The 
format of the input files needed to run IHEAT has changed between the legacy versions and IHEAT 
v4.0. Thus, the Convert Files tools allow the user to easily convert the set-up file, flow conditions 
files, and position gauge file into a format that can be read into IHEAT v4.0. These input files can 
be loaded into IHEAT using the Load Set-up File, Load Flow Conditions File, and Load Position 
Gauge File tools. The Load LUT tool has been added to IHEAT v4.0 to allow the user to select a 
specific look-up table (LUT) to load into IHEAT during the calibration of a new phosphor mix 
(without changing the set-up file for that run); however, the user should exercise caution to avoid 
using the Load LUT tool to specify the wrong LUT for the acquired data set. 

 
Images in IHEAT v4.0 can be labeled as preliminary, proprietary, or sensitive using various 

standard and user-defined specifications. Standard image and color bar titles are automatically 
generated based on the test name in the set-up file for a run, and these titles can be modified using 
the Image Titles tool. The units of the temperature image data can be toggled between English (°F) 
and metric units (°C) via the Image Units tool. 

 
Image data can be analyzed at every pixel using either the “impixelinfo” or the “datacursor” 

built-in software tools (for the current image on display), or using the Data tool (which provides 
information at that pixel location about all of the images that are currently stored in memory). Data 
can be extracted from multiple points along a single straight line drawn on the image using either 
the Length or the Profile tools, from a grid of multiple straight lines using the Auto Profile tool, or 
from a segmented line cut using the Piecewise tool. By toggling on the Activate Line Cuts Menu, 
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the end points of the straight lines easily can be duplicated from image to image within a run’s 
entire temporal data set.  

 
IHEAT v4.0 contains eighteen color map choices that can be used to view different flow, 

heating or geometric features on a model that could be visually obscured when the standard 
rainbow color map is implemented by default. The Temperature Filter also can be toggled on to 
reduce the noise in the image data or off to allow the user to examine the image for the possibility 
of very narrow features that could be blurred by the application of the median filter with a 5x5-
pixel neighborhood. The user easily can switch between the prerun temperature, run temperature, 
heat transfer and uncertainty images in the drop-down View menu (or in additional drop-down 
menus for Batch or Load Run operations). The Zoom In and Zoom Out tools allow the user to 
magnify a smaller region of the model, and the Pan tool can be used to translate the zoomed image. 

 
The Compute Heat Transfer menu allows the user to determine the heat transfer mapping for 

a selected prerun and run temperature image pair for either a fused silica ceramic or a Macor® 
wind tunnel model by toggling material buttons. If necessary, the Shift Run Image tool can be used 
to align the run temperature image with the prerun temperature image if the model location 
changed due to the sting bending in the tunnel during the run. Prior to computing the heat transfer 
data, the user can use the Check PreRun Temperature tool to verify the prerun temperature image 
displays uniform model temperature data that compares well with the temperature measured by a 
thermocouple either in the test section or attached to the back of the wind tunnel model. 

The percent uncertainty in heating at each pixel on the model can be computed for runs in 
either the 20-Inch Mach 6 or the 31-Inch Mach 10 Tunnels using the Run Uncertainty tool in the 
View menu. Extraneous data in the images (due to reflections from the tunnel windows, for 
example) can be hidden using the Mask tool, which applies the same masked region to the intensity, 
temperature, heat transfer and uncertainty images in the run. The Undo All Mask Edits tool restores 
the image regions that were hidden using the Mask tool. Regions on the model also can be queried 
using the Stats tool to determine the number of points, the maximum, minimum and mean values, 
and the standard deviation of the points in the region. 

By automating several steps in the process, the phosphor thermography data from a run can be 
reduced more efficiently. The Load Run tool facilitates batch processing by allowing the user to 
load in all of the input files and images for a run at the same time. The Save All function allows 
the user to save the full set of reduced data from a Load Run operation without needing to save 
each image individually. The Batch tool also automatically computes the heat-transfer mapping 
that corresponds to each of the temperature images in a run folder, based on how a single image 
was analyzed, and saves the appropriate data files to folders. The tutorial in the next section 
provides more detailed insight into how these and other tools are used in IHEAT v4.0. 

3.2. IHEAT v4.0 Tutorial 

This tutorial describes the features of IHEAT v4.0. In the first section of this tutorial, the menu 
items are discussed. Next, the image tools positioned in the left column of the user interface are 
explained. Finally, the Batch and the Shift Run Image operations on the right side of the GUI are 
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described. Grayed-out options that are not discussed in this tutorial (e.g., extrapolation to flight) 
are in the alpha testing phase and will be beta-tested prior to an update to the IHEAT software. 

 
1. Under File > New, the following three options appear (as shown in figure 1): New Test, 

New Run, and New Batch. The difference between these three options is as follows: 
A. New Test: Clears all of the current run variables from memory.  
B. New Run: Clears the current run variables from memory, excluding the variables from 

the set-up file. 
C. New Batch:  

1. Clears the current run variables from memory, excluding the variables from the 
Auto Profile analysis data. 

2. The Run Folder name used to determine where to perform the Batch operation does 
not change when New Batch is selected. Thus, the user can change the path and 
folder name manually either before or after selecting New Batch (refer to the Load 
Run section on page 6 for instructions on how to change folders).  

 

 
Figure 1: File Menu, New. 

 
2. The next option under File is Load Data File. This menu item is used to load a saved 

phosphor thermography run into the IHEAT v4.0 software.  
 

3. The following three items in the File menu in figure 1 are the Load Setup File, Load Flow 
Conditions File and Load Position Gauge File options. These options are used to bring in 
the required information about the facility and the flow conditions to reduce a new 
phosphor run. These files can be loaded into the software in any order. When a new file is 
loaded into the software, the variables extracted previously from a file of the same type are 
overwritten. The file name extension for each of these file types is as follows: set-up files 
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end in “.ihs”, flow conditions files end in “.tekflw”, and position gauge files end in 
“.tektxt”. If a required file is not loaded into the software before the Compute Heat 
Transfer button is selected, an error message appears that requests the missing information.  

 
4. Under File > Load Raw Images in figure 2, two options appear: Load PreRun Image and 

Load Run Image. The calculated temperatures are shown for each of these images. When 
either image is loaded into the software, the LUT (specified by the set-up file or in the Load 
LUT tool) is applied and the image appears in the middle box in figure 2, with an 
appropriate title above and color bar to the right of the image. These images can be loaded 
into IHEAT in either order. After both images are loaded, a black border appears around 
the run image to signify the edge of the prerun image for alignment purposes.  

 

 
Figure 2: File Menu, Load Raw Images. 

 
5. A new option in IHEAT v4.0 is File > Load Run. To change the name of the run folder to 

access different files for the Load Run command, left click in the text box labeled “Run 
Folder Name” in the upper right corner of the main GUI and press “Enter/Return.” A dialog 
box appears that asks the user to select the run folder. Once the correct folder is specified, 
click open, and a message box will appear that shows the name of the new run folder.  

 
After specifying the appropriate run folder, click Load Run; at this point, the menus on 

the right side of the main GUI window will change to include those shown in figure 3. If 
another run is already open, the user is prompted to select New > Test, Run or Batch prior 
to Load Run. If set-up and position gauge files are located in the run folder, these files are 
loaded into IHEAT v4.0 (provided the run folder only contains one .ihs file). If the set-up 
file is in a different directory, a pop-up message asks the user to specify the directory that 
contains the set-up file so the file can be loaded. If the number of .tekflw files matches or 
exceeds the number of run images in the folder, the flow conditions files are loaded into a 
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drop-down menu, organized by the run time in each file. Load Run also loads in the pre-
run image as long as one, and only one, image in the run folder contains a capital “P” in 
the file name. All of the remaining .tif files in the run folder are loaded in as run images, 
and organized by frame number in the lower drop-down menu shown in figure 3.  

 
The first frame in the lower menu is paired with the appropriate flow conditions file to 

show the initial run temperature image after the Load Run operation. The images in the run 
temperature drop-down menu can be shifted after loading in the files, and the temperature 
filter for these images can be toggled on or off. The same shifting is applied to each image 
selected in the drop-down menu, unless the user manually changes the shifting amount 
when a new image is selected. 

 
When Load Run is implemented, the user must exercise caution in computing heat 

transfer results to avoid overwriting data. Only one heat transfer image is stored in memory 
at a time during a manual heat transfer analysis process (not a Batch operation), so the heat 
transfer data is overwritten each time the Compute Heat Transfer button is clicked for a 
selected flow conditions file and run frame. If the user selects View > Change Image > Heat 
Transfer, the image displayed in the main GUI will correspond to the most recently 
computed heat transfer data, which may differ from the time listed for the flow conditions 
file or the current frame in the drop-down menus. Each time the heat transfer image is 
accessed during a Load Run operation, the software displays the frame number along the 
x-axis of the image to remind the user which conditions correspond to the displayed heat 
transfer data. 

 

 
Figure 3: File Menu, Load Run.  

 
6. The next item in the File menu in figure 3 is Load LUT in which the user can load in a 

different LUT file than the one specified in the set-up file. The LUT file must be a .dat file. 



 8 

Two header lines are included at the top of this file. The most recently loaded LUT file 
overwrites the LUT file data previously loaded into IHEAT v4.0.  
 

7. Under File > Temperature Filter, the user has the option to toggle the temperature filter on 
or off any time prior to computing the heat transfer. When applied, a median filter with a 
5x5 neighborhood of pixels reduces the “salt-and-pepper” noise in the pixels of the image. 
A Sobel filter enhances the edges in the image and ensures the median filter is not applied 
in regions with strong gradients. Closing the Temperature Filter tool updates the visible 
image (excluding previously computed heat transfer data) to reflect the filter settings. A 
check mark appears beside the Temperature Filter menu item if the filter is on. 

 
8. Another feature in the File menu is the Activate Line Cuts Menu. When this menu is toggled 

on, a check mark appears beside the item in the File menu, and the user interface changes 
as indicated by the red box in figure 4. This item allows the user to type in the (x, y) pixel 
locations for the endpoints of a line cut. When the user specifies two x values and two y 
values in the text boxes, the slope of the line is automatically calculated and displayed. 
After a line is specified, the reset button can be used to change the five text boxes back to 
the default strings shown in figure 4.  

 
The Activate Line Cuts Menu option can be used in conjunction with the Length or 

Profile image tools discussed later. After specifying the end points in the text boxes of this 
menu, if the user enters one of these two line cut tools, a line will appear on the image in 
the specified location. The end points can be changed while the line cut tool is running, 
and the position of the line on the image will change accordingly. Prior to following the 
prompts in the line cut tool to view the data from the line cut, the user must first click 
somewhere inside the image when these text boxes are in use.  

 
The pixel values of the endpoints of the line cannot be less than one or exceed the 

maximum pixel values in the horizontal and vertical directions for the given image. If a 
value is entered that is outside this range, the pixel value of the nearest edge on the image 
automatically replaces the given value. When the Activate Line Cuts Menu item is toggled 
off, the strings in the text boxes revert to the default values, and the buttons used in this 
tool are hidden. Otherwise, the values are retained until the reset button is clicked. 

 
9. The next category in the File menu is the Save button, which has eight options: Data, ASCII 

Heating Data, ASCII All Data, Heating MAT File, JPEG, PNG, and TIF, All Frames.  
A. File > Save > Data: For individual frame analyses, this option saves the progress on 

the data reduction, so the data file can be reloaded into IHEAT v4.0 to continue the 
reduction at a later time. In Batch operations, all of the data that corresponds to the heat 
transfer image that was most recently selected is saved using this tool. In Load Run 
operations, the most recently selected flow conditions file and run temperature frame 
are saved using this tool, along with the other data stored in memory.  

B. File > Save > ASCII Heating Data: This option saves the heat transfer data at each pixel 
location to a .dat file that can be opened in external software. 
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C. File > Save > ASCII All Data: This option saves the green and red intensity, prerun 
temperature, run temperature, and heat transfer data at each pixel location to a .dat file 
that can be opened in external software. 

D. File > Save > Heating MAT File: This option saves the heat transfer data at each pixel 
location to a .mat file. 

E. File > Save > JPEG/PNG/TIF: These options will save the current image in the middle 
box of the overall IHEAT v4.0 user interface in the specified format.  

F. File > Save > All Frames: For a Load Run operation, this item saves all of the images 
and parameters loaded into memory. Note: This option is disabled after a Batch 
operation because all of the frames are automatically saved during a Batch process. 

 

 
Figure 4: File Menu, Activate Line Cuts Menu. 

 
10. The Exit menu item at the bottom of the File menu or the “x” in the upper right corner of 

the IHEAT v4.0 GUI close the software. Both methods open a dialog box to ask the user 
whether the IHEAT v4.0 software should be closed, since unsaved data will be lost when 
the GUI closes. 

 
1. Using View > Refresh Image, the user has the option to refresh the image shown in the 

middle box of the IHEAT v4.0 GUI. This function will remove a line from a Length, Profile, 
or Piecewise line cut, the grid from an Auto Profile analysis, or points from a Data 
operation that were not hidden when those tools were exited. This function will also show 
the most recent changes applied by the Mask or Undo Mask operations, and will apply the 
currently selected color map and temperature filter. Most changes to the image should be 
applied automatically, but the Refresh button can be used as needed.  
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Figure 5: View Menu, Change Image. 

 
2. The next item on the View menu is Change Image. The options under this item change from 

the eight items in figure 5 for an individual frame, to five items if Load Run is used, or four 
items if Batch is used. The intensity images are the red or green color planes of the images. 
The following outline shows which options are available for the three types of data 
processing.  
A. View > Change Image > Intensity > Prerun Red Intensity/Prerun Green Intensity: These 

options are both available for all three types of data reduction, since only one prerun 
image is used for a given run.  

B. View > Change Image > Intensity > Run Red Intensity/Run Green Intensity: These two 
options are available for individual frame and Load Run analyses.  

C. View > Change Image > Prerun Temperature: This option is available for all three types 
of data reduction. If the temperature filter is toggled on or off and the prerun image is 
selected, the appropriate change will be applied to the visible image.  

D. View > Change Image > Run Temperature: This option is only for individual frame 
analyses since multiple run temperature images can be accessed from the drop-down 
menus after Load Run or Batch operations.  

E. View > Change Image > Heat Transfer: This option is available during individual frame 
or Load Run data analyses. During Load Run, the most recently calculated heat transfer 
image is available, which may not correspond to the currently selected flow conditions 
and run image files in the drop-down menus, as discussed previously in the Load Run 
section. 
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F. View > Change Image > Run Uncertainty: This option is available for all types of data 
reduction within IHEAT v4.0. The run uncertainty image shows the combined value of 
the individual root mean square uncertainty values at each pixel on the model. 

 
3. Under View > Image Units, the user can switch between metric and English image units.  
 
4. Under View > Image Titles, the user can change the title listed above the image as well as 

the color bar title. Although the values of the Mach and Reynolds numbers and the nose 
radius cannot be changed, the user can choose whether these values are displayed in the 
title. The user must supply the angle of attack for the run. The yaw angle, flap deflection 
angle, and length Reynolds number also can be specified in this dialog box.  

 
5. The next item in the View menu is the Image Labels tool. When in use, the proprietary label 

is set up so that the company name precedes the word proprietary. The preliminary label is 
located in the lower right corner of the image until the user toggles the label off. 

 
6. The Color Bar Range tool in the View menu is used to change the scale on the color bar. 

The user can modify the default limit values for the different parameters, which are 0 to 
255 for intensity images, 0° to 170° in Celsius or 32° to 338° in Fahrenheit for temperature 
images, 0 to 1 for nondimensional heat transfer images, and 0% to 100% for run uncertainty 
images. For the default “rainbow” color map, overscaled data is pink and off-scale data is 
white. 

 
7. The next item is View > Undo All Mask Edits. This menu item can be used to remove any 

masks applied to all the images in memory. The Refresh function is automatically called so 
that the previously masked regions on the current image (and other images stored in 
memory) are again visible as data when those images are viewed in the GUI or accessed in 
data calculations.  

 
8. Under View > Color Tables, the user can change the color map that is applied to the image. 

Certain flow features or attributes of the model (such as geometric characteristics or 
fiducial marks) are more easily distinguished when different color maps are used.  

 
1. The only item on the IHEAT v4.0 Heat Transfer menu is Compute Heat Transfer. The 

whole prerun image is used to calculate the heat transfer data, correlating pixels on the 
model in the prerun temperature image to the same pixels on the model in the frames 
obtained during a run.  

 
2. The Compute Heat Transfer tool (see figure 6) allows the user to choose between fused 

silica and Macor® as the material of the model. The Reset button is included in case the 
user changes parameters in the text boxes, but then decides to restore the default values 
obtained from the flow conditions file. The user can also choose whether to calculate non-
dimensional or dimensional heat transfer coefficients by selecting the corresponding toggle 
buttons. The Compute button is clicked to perform the heat transfer calculations. 
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Figure 6: Compute Heat Transfer Tool. 

 
1. Checklists: The lists in figure 7 tell the user how to run a phosphor thermography wind 

tunnel test. The checklists are displayed in the IHEAT v4.0 terminal window, including 
sections for the Load Run, Batch, and Three-Dimensional (3D) Mapping capabilities for 
analyzing the phosphor thermography data. 

 

 
Figure 7: Help Menu, Checklists.  
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2. Phosphor Diagnostics Tool: This tool lists hints for resolving possible phosphor test 
problems, as shown in figure 8, which are viewed in the IHEAT v4.0 terminal window. 

 

 
Figure 8: Help Menu, Phosphor Diagnostics Tool. 

 
3. IHEAT Best Practices: This section outlines known best practices for a user to follow when 

running IHEAT v4.0, including solutions if certain errors are encountered while running 
the software. 

 
The formats of the phosphor thermography input files were modified from those in 

IHEAT v3.2 to work in IHEAT v4.0. However, using the Convert Files menu, the user has 
the option to update files formatted for the previous version of IHEAT for use in the newer 
version of the code. This tool allows the user to reuse existing set-up, flow conditions and 
position gauge files to reduce phosphor thermography data from earlier tests in IHEAT 
v4.0. The user must exercise caution when implementing these tools, since the files in the 
selected directory will be overwritten with the reformatted files. Selecting one file of the 
specified type in a directory is sufficient to change all such files in the same directory (for 
example, if one .tekflw file is selected in a folder, then all the .tekflw files in that folder 
will be converted).  

 
To convert a set-up file, the user must specify the wind tunnel facility in which the run 

took place (which dictates the tunnel core size and other variables necessary for the data 
processing), and the location of the .dat LUT file that will be used to convert the pixels in 
the run and prerun images to temperatures. The facility listed in the set-up file is 
automatically determined and specified in the dialog box in figure 9, although the user can 
override that specification if the facility is incorrect. To specify the LUT location, the user 
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clicks the Find button and navigates to and selects the .dat LUT file. The user clicks Apply 
to complete the conversion of the set-up file. 

 

 
Figure 9. Convert Files Menu, Set-up Parameters. 

 
Note: These conversion tools assume a specific format for each type of input file. If the 

code cannot successfully interpret and convert a given file with a different initial format, 
the user may need to manually modify the format of the file to work in IHEAT v4.0. 

 
Most of the tools in the toolbar menu are built-in functions in the overall scripting language 

used to compile the software that provide information about the IHEAT v4.0 images, with the 
exception of the Insert Text Box and Edit Text Box tools.  

 

1. The first item to the left in the red circle in figure 10 is the data point cursor. After 
clicking on this tool, the user can click anywhere in the image to obtain data for a given 
pixel location. As the data point on the hemisphere model in figure 10 shows, this tool 
lists the x and y pixel location, the color index, and the red, green, and blue indices for 
the point on the image indicated by a black rectangle. The color index will be the 
intensity, temperature, heat transfer, or uncertainty value at the pixel indicated on the 
model, depending on which parameter is displayed in the image.  

 
With the left mouse button, the user can either click on a different pixel location in 

the image or drag the current data point to a different position to change the location of 
the current data point. Right clicking on this data point opens another menu, also shown 
in figure 10, which allows the user to delete data points (called a datatip in the built-in 
menu), create a new data point, or change the style of the tool. Though the option to 
Export Cursor Data to Workspace is visible in this default menu, this option does not 
work correctly in the stand-alone executable IHEAT v4.0 software, and therefore, 
should not be used. 
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Figure 10: Toolbar Menu, Data Point Cursor. 

 
2. The white icon with a black “P” in the toolbar is the Pixel Information tool. When the 

user clicks on this tool, the pixel information appears in the lower left corner of the user 
interface, as circled in red in figure 11. As the user moves the cursor over the image, 
the pixel information is updated. This tool displays data for the current image to two 
decimal places of accuracy per the default settings of the scripting language in which 
the software is compiled. In the Length, Profile, Piecewise, Auto Profile, Stats, and 
Mask tools, the Pixel Information tool is activated to show the user the pixel location 
of the cursor as the lines, points, or rectangles, respectively, are drawn. 
 

3. The next two buttons on the toolbar menu in figure 10 resemble magnifying glasses 
with either a “plus” or a “minus” sign in the middle. These tools allow the user to zoom 
in or out from an image, respectively. When the Zoom In button is highlighted, the 
image is magnified by a factor of two each time the user single-clicks on the image 
with the left mouse button, or rotates the mouse scroll wheel forward one click. Another 
way to zoom into the image is to drag the mouse (while depressing the left mouse 
button) over a region of interest on the image. To zoom out, the user can rotate the 
mouse scroll wheel backward one click or hold the shift key while clicking on the image 
with the left mouse button. When the user double-clicks on the image, the original view 
is restored. The user can also right click to see zoom options, as shown in figure 12, 
such as Reset to Original View. If the Zoom Out button is selected, the same zoom 
options are available, except the left-click and shift + left-click options are reversed.  

 
4. The next icon in the toolbar menu in figure 10 allows the user to pan a zoomed image. 

When the Pan tool is selected, the cursor icon changes to a hand when the user scrolls 
over the image, which resembles the hand enclosed in red in figure 12. The user then 
can click and drag points on the image with the left mouse button to pan the image. A 
right click shows a menu with pan options similar to the zoom options described above. 
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Figure 11: Toolbar Menu, Pixel Information. 

 

 
Figure 12: Toolbar Menu, Zoom and Pan. 

 
5. The last two icons in the toolbar menu allow the user to either insert or edit a text box 

to place user-defined labels on the GUI image. These tools therefore have icons labeled 
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ITB and ETB for Insert Text Box and Edit Text Box, respectively. The user can specify 
the parameters of the text box as shown in the input dialog for the ITB tool in figure 13 
and place the text box in the appropriate location on the image as shown in figure 14. 
The ETB tool allows the user to later change the location of the text box, the number 
of lines of text in the box, and the words in the text box. 

 

 
Figure 13: Toolbar Menu, Insert Text Box (ITB) Tool, Input Dialog. 

 

 
Figure 14: Text Box Inserted using the ITB Tool.  
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1. Length/Profile: The same procedure is used to operate both the Length and the Profile tools, 

so only the Length tool is demonstrated in this tutorial. In figure 15, the Length tool is 
selected, and a blue line is drawn on the image. To draw the line, the user can either click 
and drag a line on the image (as was done in this case) or type the endpoints of the line into 
the Activate Line Cuts Menu text boxes prior to entering either the Length or the Profile 
tool. If the latter option is used, the user must click somewhere in the image after clicking 
on the button for the line cut tool and before pressing “g” to extract the line cut data. For 
more information on how to create a line using this method, refer to the Activate Line Cuts 
Menu description in the File menu section at the beginning of this tutorial. 
 

When the user manually creates the line by clicking and dragging, the second endpoint 
of the line is placed when the user releases the left mouse button. The line may not extend 
beyond the edges of the image; any endpoint placed beyond these boundaries is 
automatically changed to the closest edge of the image. To change the position of the line 
manually, the user may left click on either endpoint and drag it to a different position within 
the image. The Pixel Information tool is activated when the Length or Profile tools are 
implemented, so the user can select appropriate pixel locations for the endpoints of the line 
based on the coordinates provided in the lower left corner of the user interface.  

 

 
Figure 15: Image Tools, Length and Profile. 

 
While either the Length or the Profile tool button is red, the tool is active and more line 

cuts can be taken. Other image tools are disabled while either the Profile or the Length 
tools are active (and thus, the other tools temporarily are not visible on the GUI). The 
reference dimension used to normalize the x data in a line cut made with the Profile tool is 
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either the length of the most recent line cut taken in the Length tool, or the length of the 
current Profile line cut if the Length tool has not been used in the IHEAT v4.0 session. 

 
A message below the image in the GUI in figure 15 tells the user to type “g” on the 

keyboard to plot the line cut data. Figure 16 shows the Save dialog and plotted line cut data 
that appear when “g” is pressed if the run temperature image is visible in the user interface. 
The Save window must be closed before the user can modify the line cut or exit the Length 
or Profile tool. The line cut data in the figure can be saved using the File menu. The Edit 
menu in the figure allows the user to add a text box to the figure or change the figure title, 
the axes limits and the axes labels. The other icons in the figure toolbar menu allow the 
user to view and analyze the line cut data. The Save dialog box gives the user the option to 
save ASCII line cut data in either a .dat file or a .txt file.  

 

  
Figure 16: Image Tools, Length: Line Cut Data and Save Dialog. 

 
2. Piecewise: Another feature of IHEAT v4.0 is the Piecewise tool, demonstrated in figure 17. 

This tool is similar to the Length tool, but allows the user to create a segmented line cut. 
The message below the image tells the user to press “n” to create a new line or “p” to plot 
the line cut data. When a new line is created, the user can left click on the end of the current 
line and drag the mouse to another position to define the new line segment. If “n” is not 
pressed after a line is drawn, clicking and dragging the final endpoint of the most recent 
line segment will change the position of that line segment on the image. Only the position 
of the newest line segment can be modified; all of the other line segments remain stationary. 
If the last line segment is one pixel long, this segment is automatically deleted before the 
data is plotted. A Piecewise line cut can contain any number of line segments.  

 
The heat transfer data in figure 18 is extracted from the Piecewise line cut in figure 17 

when “p” is pressed. The x/L dimension extends from zero at the first endpoint to one at 
the last endpoint along the overall segmented line. Once the data has been plotted, the 
message below the image changes to tell the user to either exit the Piecewise tool or press 
“c” to create a new Piecewise line cut. The Save dialog box shown in figure 18 must first 
be closed before a new line cut can be created or the tool can be exited. The user also must 
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click in the image window before pressing “c” to make the main IHEAT v4.0 GUI the 
active figure again to enable the Piecewise tool to create a new line cut.  

 

 
 Figure 17: Image Tools, Piecewise. 

 

  
Figure 18: Image Tools, Piecewise: Line Cut Data and Save Dialog. 

 
When the user exits the Piecewise tool, the location of the most recent Piecewise line 

cut is stored in memory and can be used in the Batch tool (described later) to apply the 
same line cut to every frame in the run folder. If the user reenters the Piecewise tool during 
the same IHEAT v4.0 session, a pop-up message allows the user to load the existing line 
cut or create a new line cut. If the existing line cut is selected, the user can press “n” to add 
new line segments to the end of the line. After the user plots the Piecewise line cut data, 
the option to press “c” to clear the existing data and create a new line cut again is available. 
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3. Auto Profile: When the Auto Profile tool is first entered, the button that corresponds to the 
visible image plane is highlighted, and the line cuts extracted from the set-up file are 
displayed in a tab-delimited list. A different plane is displayed when the corresponding 
button in figure 19 is clicked. To add a new line cut location, the user can type in the x/L 
or y/yref location in the appropriate text box, leaving at least one space between the values. 
The line cuts do not have to be entered in order numerically, because these lists will be 
rearranged automatically. The user can enter a maximum of 25 axial and 25 longitudinal 
line cuts.  
 

The Auto Profile Image button saves a snapshot of the image, the title and the color bar 
shown in the middle box of the IHEAT v4.0 user interface as a .jpeg file. This button can 
be used at any time while the Auto Profile tool is in use. 

 

 
Figure 19: Image Tools, Auto Profile. 

 
As figure 19 shows, the Auto Profile tool in IHEAT v4.0 requires the user to select the 

Fixed Ref or Symmetry Ref option to begin an Auto Profile analysis. The Make Cuts option 
is disabled until the reference line and fiducial marks are placed on the image as shown in 
figure 20. The first time the Auto Profile tool is entered for a run and either the Fixed Ref 
or the Symmetry Ref button is pressed, the user must enter at least two x and two y values 
in fiducial marks before closing Auto Profile.  

 
After the required fiducial marks are entered, additional points are created individually 

according to the user’s needs. An error message appears when the user repeats a previous 
x or y fiducial mark value, and the new fiducial mark is removed. To change the location 
of a fiducial mark with a given value, the previous point with the same value first must be 
deleted. When the user clicks on or near an existing fiducial mark, the choice to either keep 
or delete the mark is presented. Deleted fiducials are displayed on a list and disappear from 
the image after the Refresh button is clicked or when Auto Profile is closed and reentered. 
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Figure 20: Image Tools, Auto Profile: Reference Line and Fiducial Marks. 

 
As figure 20 shows, the fiducial mark values are labeled in IHEAT v4.0. The user can 

either enter one or both of the nondimensional values for a given fiducial mark, which 
correspond to x (or x/L) and y (or y/yref). Examples of the labels in each case are shown in 
the figure. If the Auto Profile tool is later reentered, these labels are again visible. View > 
Refresh can be used to hide any marks or lines that are still visible after the Auto Profile 
tool is exited.  

 
4. The Make Cuts dialog box has several options for viewing and saving line cuts from an 

Auto Profile analysis (see figure 21).  
A. When the Select All Lines Cuts item is toggled on, the axial, longitudinal and reference 

line cuts are toggled on; when this item is deselected, all of the line cuts are toggled 
off. The line cuts also can be toggled on or off individually.  

B. Show All Line Cuts toggles all the line cuts on and opens figures with the line cut data. 
If this option is deselected, open figures with line cut data (as well as any other open 
figures created during the data reduction process, excluding the IHEAT v4.0 main and 
sub-GUIs) are closed using a “close all” command. 

C. Two options exist to save line cut data from the Auto Profile analysis, including a 
combined data file with all of the line cuts, in appropriate folders within the current 
directory listed in the Run Folder text box. 
1. Save All allows the user to save all the line cut data from the Auto Profile analysis.  
2. To exclude line cuts during a Save operation, the user can select the specific line 

cuts to be saved and click Save.  
D. Quit allows the user to exit the Make Cuts tool without saving any of the Auto Profile 

line cuts. 
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Figure 21: Image Tools, Auto Profile: Make Cuts. 

 
5. Stats: The Stats tool in IHEAT v4.0, shown in figure 22, provides information about a 

rectangular region of interest (ROI) on the image. After selecting this tool, the user must 
left-click on the image and drag the mouse to generate the rectangular ROI, releasing the 
left mouse button when the ROI is correct. This procedure yields a histogram and a set of 
statistics for the ROI, as shown in figure 23. These statistics are provided: the number of 
points in the ROI, the maximum value, the minimum value (greater than zero), the mean 
value, and the standard deviation of the ROI data. The ROI cannot be modified in this tool, 
so the Stats tool must be closed and reentered to evaluate a different ROI in the image. 

 

 
Figure 22: Image Tools, Stats.  
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Figure 23: Image Tools, Stats: Histogram and ROI Data. 

 
6. Mask: Figure 24 shows the Mask tool used to hide an ROI on the image, and figure 25 

shows the same image after the masked ROI is hidden (by exiting the Mask tool, which 
calls the Refresh function). The user can mask multiple regions of the image at a time by 
dragging the corners of the Mask rectangle to different locations on the image. All of the 
pixels within the rectangle are masked, so the user should not position the rectangle over 
any useful data in this process. All of the masked regions are hidden from view by setting 
the data for those pixels equal to zero. View > Undo All Mask Edits restores the original 
images and data (refer to the description of Undo All Mask Edits in the View menu section). 
When the Batch tool is used, any regions that have been hidden in the example run image 
using the Mask tool also will be masked in the Batch data files. 

 

 
Figure 24: Image Tools, Mask.  
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Figure 25: Image Tools, Mask: Refresh Applied. 

 
7. Data/Print Data Tools: The combined Data and Print Data tools are shown in figure 26. 

When Data is clicked, a black point appears in the upper left corner of the image and the 
Print Data button is enabled. All of the data that are available at the specified pixel location 
(for images up to, and including, the visible image) are listed in the appropriate text boxes 
under the Data button. Since the heat transfer image is shown in figure 26, the first four 
text boxes contain information. The Intensity text box refers to the data from the green pre-
run intensity image plane. The user can either drag the point to a different pixel location on 
the image, or type the new pixel coordinates directly into the text boxes labeled X and Y.  
 

 
Figure 26: Image Tools, Data and Print Data.   
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The Print Data button in figure 26 allows the user to save the information about the 
current data point to a .txt file. Once the Data tool is exited, the Print Data button is 
disabled and the strings in the text boxes are replaced with the default “---” strings. The 
Data tool can be useful in determining which pixels to select in line cuts or an Auto Profile 
analysis.  

 
The available menus, text boxes and buttons in the right column of the main IHEAT 

v4.0 GUI change depending on the tools that the user accesses. These tools (excluding the 
Activate Line Cuts Menu option explained in the File menu section) are described below.  

 
1. Batch: Prior to a Batch operation, the user either must create a Piecewise line cut or perform 

an Auto Profile analysis and select Make Cuts to generate a grid of line cuts for at least one 
frame in the run folder. This line cut (for Piecewise) or grid of line cuts (for Auto Profile) 
is applied to all of the run images in the Run Folder during a Batch operation. The user can 
update the name of the run folder in the manner described in the Load Run description in 
the File menu section above.  

 
The user has the option to calculate either dimensional heat transfer coefficients or non-

dimensional heat transfer coefficients divided by the Fay-Riddell reference coefficient. In 
the Batch operation, the type of heat transfer coefficients calculated for each frame in the 
run folder matches the dimensionality of the coefficients calculated in the initial analysis. 
For a Batch operation that uses an Auto Profile grid, the Batch function also produces a 
combined data file that includes the y/yref = 0 line cut from each of the reduced frames in a 
semicolon delimited file that can be read into external software to perform a check of the 
temporal collapse of the data. If the y/yref = 0 line cut is not included in the initial Auto 
Profile analysis, this file lists the reference line cuts instead. When the Batch button is 
selected, messages are displayed in the IHEAT v4.0 terminal window (as shown in figure 
27 for an Auto Profile grid) as each individual image is saved.  

 

 
Figure 27: Image Tools, Batch: Output Messages.  
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When the Batch operation finishes, the first image in the heat transfer drop-down menu 
is displayed, as in figure 28. This menu and the frame menu are added to the GUI to allow 
the user to view the run temperature and heat transfer images in the run folder. The Auto 
Profile and Mask tools are disabled after the Batch operation. All of the run frames are 
saved automatically during the Batch operation. The user can modify any frame and save 
the updated data to a new output file using Save > Data. The user also can open a saved 
data file to perform a new Auto Profile analysis or use the Mask tool on an individual basis. 

 

 
Figure 28: Image Tools, Batch: User Interface with Drop-Down Menus. 

 
As the plots in figure 29 show, for Batch operations using an Auto Profile grid, a 

separate figure appears that shows the temporal collapse of the y/yref = 0 line cuts (or the 
reference line cuts if the y/yref = 0 line cut does not exist) for the computed heat transfer 
images from the run folder. If the user closes this figure and then needs to examine the line 
cuts again, clicking on the Plot CL Cuts button during the same IHEAT session will redraw 
the figure. For Batch operations that use a Piecewise line cut, a plot is displayed that 
compares the Piecewise line cut data for every frame. In both cases, the legend initially is 
positioned outside of the upper right corner of the plot (as shown in the left image in the 
figure), but the user can select and drag the legend to an appropriate position within the 
plot as desired (as in the right plot). 

 
The user can specify which frames to include in a copy of the temporal collapse figure 

by selecting the Temporal Collapse Range item in the Edit menu. The range of frames can 
be continuous or specified in intervals. For example, if images numbered 50 to 95 were 
recorded in a run, the continuous range 11:20 would include frames 60 through 69 (as 
displayed in the left plot), while the incremented range 1:5:46 would include every fifth 
frame between 50 and 95 (as shown in the right plot in the figure). If a large number of 
frames are included in the original figure, the user can enter a frame number in the region 
of interest to learn the position of that frame in the list prior to specifying the range of line 
cuts to include in the new figure.  
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Figure 29. Image Tools, Batch: Temporal Collapse Plot. 

 
For any Batch operation, the user should select File > New Batch prior to clicking the 

Batch button to clear space in the memory for the required variables for Batch operations.  
 

2. Shift Run Image: The run temperature image can be shifted to align the image with the pre-
run temperature image, using the black outline of the prerun image as a guide. Figure 30 
shows the run temperature image shifted in the opposite direction. The user can either type 
the number of pixels to shift the run temperature image directly into the text boxes, or use 
the up, down, left, and right buttons (shown in the red box in figure 30) to shift the image 
one pixel at a time. The values in the text boxes indicate the full number of pixels the image 
has been shifted; thus, if the user enters “0” in both text boxes, the run temperature image 
returns to the original position, negating all the shifting operations. 
 

 
Figure 30: Image Tools, Shift Run Temperature Image.  
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1. Many GUIs are set up to accept “Esc” for Cancel or “Enter/Return” for OK, particularly: 

A. New Test  
B. New Run  
C. New Batch  
D. Save  
E. Exit  
F. Color Bar Range (which also accepts the letter “A” as a shortcut for Apply)  
G. Heat Transfer Parameters (where “Esc” is used for Quit, “Enter/Return” for Compute) 

* Note: These shortcuts require the correct window to be active, and will not work if 
the user is typing in a text box, even in the correct GUI.  

 
2. If the user clicks on the icon in the upper left corner of each GUI, several options appear 

that allow the user to control the position of the GUI. For example, the user can choose to 
keep the GUI in front of all other windows on the current workspace, to move the GUI to 
another workspace, or to keep the GUI on the current workspace. These features are 
especially helpful when the user starts up IHEAT on one workspace and switches to another 
workspace to complete other tasks while IHEAT runs. 
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3.3. IHEAT v4.0 Flow Chart  

 

ACCESS SERVER-Page 1

Open a Secure Shell or X terminal window

PC - Windows

To 
OPEN IHEAT

Page 2

Note 1: The terms “server” and 
“user name” stand for the server 
on which IHEAT is compiled and 
the user name of the person 
accessing IHEAT 4.0

ACCESS SERVER PROCEDURE TO RUN IHEAT 4.0 FOR A 
THERMOGRAPHIC PHOSPHOR TEST

Start

Apple - Macintosh
Operating 

System

Open a terminal window

Currently 
running a node 

on server
(See Note 1)

1. Type “vncviewer server:#” in a terminal 
window and press Return, or open a 
virtual network computing (VNC) viewer 

2. Enter the “desktop” number in the 
“Display” box

3. Provide the user’s password for the 
server

4. Each time the user closes the window 
used to remotely access the server, it can 
be reopened by repeating steps 1-3

5. To end a connection that is not working 
properly, type “ssh server” and press 
Return in a terminal window, then type 
“vncserver -kill server:#” and press Return

NO

Operating 
System

Apple - Macintosh

1. Connect to the server using “ssh”
2. Type “vncserver -geometry 1700x1200” and 

press Enter/Return (See Note 2)
3. Message will appear: “New ‘server:# (user 

name)’ desktop is server:#”
4. Type exit and press Enter/Return to leave 

the server
YES

1. Open a new remote connection
2. Ensure the “Remote Host” or “VNC 

server” is the name of the new desktop 
(i.e., server:#) and click Connect

3. Provide the user’s password for the 
server

4. Each time the user closes the window 
used to remotely access the server, it can 
be reopened by repeating steps 1-3

5. To end a connection that is no longer 
working properly, connect to the server 
via ssh in a Secure Shell or X terminal 
window and press Enter, then type 
“vncserver -kill server:#” and press Enter 

PC - Windows

Note 2: The 1700x1200 
dimensions are listed as an 
example and should be modified 
to produce a properly sized 
window on the user’s monitor
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From 
ACCESS SERVER

Page 1

OPEN IHEAT-Page 2

NO

To 
REDUCTION 

Page 3

Note 2: If IHEAT 4.0 does not open, 
try typing “chmod +x iheat40” in 
the terminal window and press 
Enter/Return

Note 1: Each time a new terminal 
window is opened to run IHEAT, the 
command “module load mliheat” 
must be repeated prior to the first 
time IHEAT 4.0 is called

OPEN IHEAT PROCEDURE TO RUN IHEAT 4.0 FOR A 
THERMOGRAPHIC PHOSPHOR TEST

While remotely accessing a desktop on the server:
1. Right-click and select “Open Terminal”
2. Type “module load mliheat” in the terminal window (See Note 1)
3. Type “/usr/local/bin/iheat40” to open IHEAT 4.0 GUI (See Note 2)

Is “hold” the 
default terminal 

profile?

1. Right-click and choose “Open Terminal”
2. Select “Edit” > “Profiles…”
3. Choose “Edit” for “default” profile
4. In the “General” tab, change the profile name to “hold”
5. In the “Title and Command” tab, change “When 

command exits:” to “Hold the terminal open”
6. Close open dialog boxes to save profile

YES

General Note: If user navigates to the run directory 
prior to opening the IHEAT 4.0 GUI, the run folder 
for that session will automatically be set to the 
specified run folder, but this step is not required



 32 

From 
OPEN IHEAT

Page 2

REDUCTION-Page 3

Under File tab: 
1. Select Load Data File 
2. Browse to the 

directory that 
contains the file

3. Select the saved 
data file and press 
Enter/Return
(See Note 1)

On right hand side of the GUI:
1. Choose the desired folder in 

the Run Folder Name text 
box by clicking in the box 
and pressing Enter/Return

2. Select File > Load Run 
3. Specify .ihs set-up file, if 

requested
4. Select .tekflw file from the 

Choose Flow Conditions File
drop-down menu

5. Select run temperature file 
from the Choose Frame to 
Reduce drop-down menu

YES

NO

To 
REDUCTION 

Page 4

Note 2: cd to the test directory 
and select the “Tx.ihs” file, 
unless the setup file is still in 
memory from a previous run

Note 3: Change the filter to “All 
Files” and click on “xytn.tekflw” 
file where n is the correct flow 
conditions timed file

REDUCTION PROCEDURE TO RUN IHEAT 4.0 FOR A 
THERMOGRAPHIC PHOSPHOR TEST

Note 4: If this file is not still in 
memory from a previous run, 
click on the “xy?.tektxt” file 
(where the ? is a file descriptor 
that changes per test) and verify 
the effective time is correct

Note 5: Ensure the 
temperatures in the Prerun 
image (named “txryPrerun.tif”) 
are uniformly similar to the 
initial test section temperature 
between about 70°F and 80°F

Note 6: Check for run image 
shifting (in the “txry_f_z.tif” 
file) and, if necessary, shift 
the run image using the text 
boxes and the Shift Run Image 
button or the shift direction 
buttons in the GUI

Note 1: Ensure the user has 
read/write access to the files in 
the directory containing the 
data to be reduced

Under File tab:
1. If a data file is currently open in 

IHEAT, highlight New and select 
the appropriate option (either 
New Test, New Run or New Batch)

2. ​Load Setup File (See Note 2) *
3. ​Load Flow Conditions File (See 

Note 3) *
4. ​Load Position Gauge File (See 

Note 4) *
5. ​Load Raw Image→ Load Prerun 

Image (See Note 5) *
6. ​Load Raw Image→ Load Run 

Image (See Note 6) *

Load Run Load Existing 
Data File

Create New 
Data File

NO
END

NO

YES YES

* General Note: x is the current test 
number, y is the current run number,
and z is the current frame number in 
the file naming convention



 33 

From 
REDUCTION

Page 3

REDUCTION-Page 4

Under Heat Transfer Tab:
1. Select Compute Heat Transfer

a) Choose the Nondimensional toggle button to change 
the units to h/href, or choose the Dimensional toggle 
button to show the dimensional heat transfer values 
instead

b) Click Compute (See Note 1)
2. If the user changes any of the variables in the text boxes, 

click the Reset button to return to the default values (as 
needed)

Under View Tab: (See Note 2)
1. Click on the Image Titles tab

a) Define the angle of attack (which is empty by default) and click 
the OK button

b) Change other subtitles as necessary
2. Click on the Color Bar Range tab

a) Change the minimum and the maximum values to appropriate 
values (as needed) and click the Apply button to see how the 
updated color bar changes the image

b) Click the OK button once the modifications are acceptable to 
close the Color Bar Range GUI

3. Click on the Image Labels tab (as needed) to control which 
descriptive labels are shown on the image in the main IHEAT GUI

To 
REDUCTION 

Page 5

Note 1: Ensure the correct 
material is selected

Note 2: Other options 
available under the View
tab are not discussed in 
this flow chart, such as 
the Image Units tool to 
allow the user to toggle 
between metric and 
English units

REDUCTION PROCEDURE TO RUN IHEAT 4.0 FOR A 
THERMOGRAPHIC PHOSPHOR TEST

Changes to Image 
Required

YES

NO



 34 

REDUCTION-Page 5

From 
REDUCTION 

Page 4

YES

NO

Mask Tool:
1. Click the Mask button (the button turns red)
2. Draw a box around the section to be masked
3. Click the Mask button again to exit the tool (the button 

reverts to gray)
4. Go to View → Refresh Image, if needed
5. To restore masked data, use View → Undo All Mask Edits

YES

NO

YES

Shift Tools: (on the bottom right side of the main IHEAT GUI)
1. Click in the text box of the direction you desire to move 

the image: (Left (-)/ Right (+)) or (Up (-)/ Down (+))
2. Type in the appropriate box the number of pixels the 

image should move in that direction
3. Click Shift Run Image to see the change
OR:
Click on the Up, Down, Left, and Right buttons to move the 
image one pixel in the specified direction

Stats Tool:
1. Click the Stats button (the button turns red)
2. Draw a box around the region of interest to gather 

statistical data
3. Manually record the statistical results in desired format
4. Press the OK button and close the histogram and data 

windows
5. Click the Stats button again to exit the tool (the button 

reverts to gray)

To 
REDUCTION 

Page 6

REDUCTION PROCEDURE TO RUN IHEAT 4.0 FOR A 
THERMOGRAPHIC PHOSPHOR TEST

Shift 
Image

Mask 
Image

Statistics
Required

NO

Note: Specifying 0 in both the
Left/Right and Up/Down text boxes 
returns the image to the original 
translation (zero shifting applied)
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YES

REDUCTION-Page 6

From 
REDUCTION 

Page 5

To
AUTO CUTS

Page 10

From 
AUTO CUTS 

Page 10

Auto MethodManual Method

NO

To
AUTO BATCH

Page 12

To 
SAVING FILES 

Page 7

REDUCTION PROCEDURE TO RUN IHEAT 4.0 FOR A 
THERMOGRAPHIC PHOSPHOR TEST

Determine 
Cut Method

Piecewise 
Batch

3D Map

From
AUTO BATCH 

Page 12

To
3D Map

(Beta Testing*)

From
3D Map

(Beta Testing*)

YES

NO

To
MANUAL CUTS 

Page 8

From 
MANUAL CUTS 

Page 9

To
MANUAL BATCH

Page 11

From
MANUAL BATCH

Page 11

Auto Profile 
Batch

NO

YES

NO CUTS

* Note: The 3D mapping 
algorithm is in the beta testing 
stage. This tool will be 
described in the tutorial and the 
flow chart when the 3D Map 
module is integrated in to the 
production version of IHEAT.
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SAVING FILES-Page 7

Under File tab:
1. Press Save → Heating MAT File
2. Specify the file name for the data
3. Press the Save button (the Save dialog 

boxes will disappear after the heating data 
file is saved)

END

SAVING FILES

From 
REDUCTION 

Page 6

PROCEDURE TO RUN IHEAT 4.0 FOR A 
THERMOGRAPHIC PHOSPHOR TEST

NO

Under File tab:
1. Press Save → Data
2. Select the Yes button when asked if the 

user wants to save the data
3. Specify the file name for the data
4. Press the Save button (the Save dialog 

boxes will disappear after the data file is 
saved)

Under File tab:
1. Press Save → ASCII Heating/All Data
2. Specify the file name for the data
3. Press the Save button (the Save dialog 

boxes will disappear after the appropriate 
ASCII data file is saved)

YES

YES

YES

Save
Data

Save
ASCII

Save Heat 
Transfer 

Array

NO

NO

Was Load 
Run used?

NO

Under File tab:
1. Press Save → All Frames
2. Messages appear in the command window specifying 

the location and the file name as each .mat file is saved
3. The message “Save > All Frames Process is Complete!” 

is displayed in the command window when the last 
.mat file is saved

YESSave
All Frames

NO

YES

Under File tab:
1. Press Save → JPEG, PNG, or TIFF
2. Specify the file name for the data
3. Press the Save button (the Save dialog 

boxes will disappear after the image file is 
saved)

NO

YESSave JPEG, 
PNG, or TIFF
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MANUAL CUTS-Page 8

From 
REDUCTION

Page 6

MANUAL CUTS

1. Press the Length button (button turns red)
2. Place the crosshairs at the desired location on 

the model, left click, and then hold down the 
left mouse button

3. Drag the cursor to the second location on the 
model and release the left mouse button

4. Type “g” to plot the Length line cut data (two 
boxes will appear)

5. Save the Length data as needed per the 
instructions on MANUAL CUTS, Page 9

Press the Piecewise button (button turns red)

To 
MANUAL CUTS 

Page 9

PROCEDURE TO RUN IHEAT 4.0 FOR A 
THERMOGRAPHIC PHOSPHOR TEST

YES

NO

Note: Profile uses the Length line cut 
dimension as a reference value.

Profile

Length
NO

Piecewise

1. Press the Profile button (button turns red)
2. Place the crosshairs at the desired location on 

the model, left click, and then hold down the 
left mouse button

3. Drag the cursor to the second location on the 
model and release the left mouse button

4. Type “g” to plot the Profile line cut data (two 
boxes will appear)

5. Save the Profile data as needed per the 
instructions on MANUAL CUTS, Page 9

YES YES

NO

1. To add another line segment, type “n,” place 
the cursor over the most recently placed 
point, left click, and then hold down the left 
mouse button

2. Drag the cursor to the next desired point on 
the model and release the left mouse button

3. The user can create more line segments OR
4. Type “p” to plot the Piecewise line cut data
5. Save the Piecewise data as needed per the 

instructions on MANUAL CUTS, Page 9

Use 
Previous 

Piecewise 
Cut

YES

NO

1. Place the crosshairs at the desired location on 
the model, left click, and then hold down the 
left mouse button

2. Drag the cursor to the second location on the 
model and release the left mouse button
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MANUAL CUTS-Page 9

From 
MANUAL CUTS 

Page 8

MANUAL CUTS

YES

YES

1. Select from the available toggle options to save 
Intensity, Prerun Temperature, Run Temperature, Heat 
Transfer, or Uncertainty data (See Note)

2. Click the appropriate toggle button to save the data 
either as a .dat or a .txt file and click Save 

3. Type the data file name in the text box and click the OK
button

4. The Save dialog box closes, leaving a graph of the data

PROCEDURE TO RUN IHEAT 4.0 FOR A 
THERMOGRAPHIC PHOSPHOR TEST

Save 
Line Cut 

Data

To
REDUCTION

Page 6

Line Cut 
Created

Note: If heat transfer data is available, save 
line cut data from the run temperature 
image, the heat transfer image, or both

To
REDUCTION 

Page 6
First create a line cut using the Length, 
Profile or Piecewise tool

NO

NO

Under the File tab within the figure for the line cut data:
1. Select Save As or Export Setup and choose the correct 

format of the file to save the plot of the line cut data 
from the following options:
a) As a .fig file that can later be modified
b) As an image: .eps, .jpg, .pcx, .pbm, .pgm, .png, .ppm 

or a compressed or uncompressed .tif image
c) As a .pdf file

2. Manually close out of this figure by clicking the x in the 
upper right corner after the data is saved

Plot 
Required

Click Cancel to close the 
Length, Profile, or Piecewise
Save dialog box

NO

YES

Close the open figures 
with line cut data
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Make Line 
Cuts

AUTO CUTS-Page 10

AUTO CUTS

From 
REDUCTION

Page 6

1. Click the Auto button on the left side of the main IHEAT GUI
2. Click the Intensity button in the Auto Profile GUI (if necessary 

to see the model fiducial marks more clearly, otherwise, the 
default image is the current image in the main IHEAT GUI)

3. Left click twice on the image in the IHEAT GUI to specify the 
locations of the two centerline points used to define the  
reference line (See Notes 1 and 2)

4. Specify the location of at least two x and two y fiducial marks 
(each fiducial mark only needs an x/L or a y/yref value, though 
both parameters can be specified for a single point)

To 
REDUCTION 

Page 6

PROCEDURE TO RUN IHEAT 4.0 FOR A 
THERMOGRAPHIC PHOSPHOR TEST

NO

Note 2: Zoom is available at any point 
during the Auto Profile analysis by selecting 
either of the Zoom magnifying glass 
symbols and either clicking on the image to 
zoom in/out 2x or selecting a rectangular 
region of interest to zoom in on

1. Click the Heat Transfer button (or Prerun/Run Temperature or 
Intensity) if the desired image is not already selected

2. Click the Make Cuts button 
a) To see the data from a particular line cut, click the toggle 

button beside the value of the line cut (to hide the line 
cut figure, toggle the same button off) 

b) Toggle the Show All Line Cuts button “on” to open 
separate figures with data from each line cut, or toggle 
this button “off” to close all the open Auto line cut figures

c) Click the Save All button to save all the line cut data to 
files, or the Save button to only save the selected line 
cuts, and the Make Cuts GUI will be closed; alternatively, 
click the Quit button in the Make Cuts GUI to close the 
Make Cuts GUI without saving the line cut data to files

d) Repeat steps a-c to save other image data

Click the Quit button on the 
Auto Profile GUI or simply close 
the GUI to exit the tool

Note 1: Left click in the center of the fiducial 
mark to place the centerline points

1. Click the Auto Profile Image button on the Auto Profile GUI
2. Specify the name of the jpeg image in the Save As dialog box 

and click Save

YES
Auto Profile 

Image

NO

YES
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MANUAL BATCH-Page 11

MANUAL BATCH

From 
REDUCTION 

Page 6

PROCEDURE TO RUN IHEAT 4.0 FOR A 
THERMOGRAPHIC PHOSPHOR TEST

END

Under File tab:
1. Press New → New Batch
2. Press the Yes button to clear memory for a 

new batch (the GUI screen goes blank)
3. Click the Batch button “on” again

1. A message appears in the terminal window that says 
“Loading Preliminary Files for Piecewise Batch…”

2. Notifications that the data is being saved will be visible in 
the terminal window used to run IHEAT 4.0

3. The Piecewise line cut data will be saved in folders 
labeled “txryPiecewise_dat_files.#” with file names of 
“txryfzruntemp.dat” for the run temperature data and 
“txryfzheattransfer.dat” for the heat transfer data

4. Individual data files also are saved for each frame in the 
run directory in a folder labeled “txryBatch_mat_files.#”

“Out of 
Memory” 

Error?

Click the Batch button 
on the right side of GUI

Modify 
individual 

files?

To 
REDUCTION

Page 6

NO

YES

YES

NO

Two Batch 
Options 

Available?

YES

NO

Select the Piecewise option from the drop-down menu

General Note 2: x is the current 
test number, y is the current run 
number, z is the current frame 
number, and the # distinguishes 
between different output folders 
for separate Batch operations 
within the same run directory 

General Note 1: Regions masked 
on an image prior to a Batch
operation are masked in all 
images loaded during Batch, but 
images cannot be masked either 
during or after a Batch operation 
in the same session

General Note 3: If the Batch
operation cannot be performed, 
the operation is terminated and 
appropriate error messages are 
displayed, either in the terminal 
window or in pop-up windows
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AUTO BATCH-Page 12

AUTO BATCH

From 
REDUCTION 

Page 6

PROCEDURE TO RUN IHEAT 4.0 FOR A 
THERMOGRAPHIC PHOSPHOR TEST

END

Under File tab:
1. Press New → New Batch
2. Press the Yes button to clear memory for a 

new batch (the GUI screen goes blank)
3. Click the Batch button “on” again

1. A message appears in the terminal window that says 
“Loading Preliminary Files for Auto Profile Batch…”

2. Notifications that the data is being saved will be visible in 
the terminal window used to run IHEAT 4.0

3. The line cut data from the Auto Profile grid will be saved 
in folders labeled “txryi.#” for the intensity data, 
“txryp.#” for the prerun temperature data, “txryfzt.#” for 
the run temperature data, and “txryfzh.#” for the heat 
transfer data

4. Individual data files also are saved for each frame in the 
run directory in a folder labeled “txryBatch_mat_files.#” 

General Note 2: x is the current 
test number, y is the current run 
number, z is the current frame 
number, and the # distinguishes 
between different output folders 
for separate Batch operations 
within the same run directory 

“Out of 
Memory” 

Error?

Click the Batch button 
on the right side of GUI

Modify 
individual 

files?

To 
REDUCTION

Page 6

NO

YES

YES

NO

Two Batch 
Options 

Available?

YES

NO

Select the Auto Profile option from the drop-down menu

General Note 1: Regions masked 
on an image prior to a Batch
operation are masked in all 
images loaded during Batch, but 
images cannot be masked either 
during or after a Batch operation 
in the same session

General Note 3: If the Batch
operation cannot be performed, 
the operation is terminated and 
appropriate error messages are 
displayed, either in the terminal 
window or in pop-up windows
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The following guidelines provide instructions on how to avoid some of the most common user 
errors that cause problems in running IHEAT v4.0. 
 

 

 

 

 

 

 

mailto:michelle.mason@nasa.gov
mailto:shann.j.rufer@nasa.gov
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The process of debugging the IHEAT software will continue as new tools are implemented and 
old modules are updated to be more efficient and user friendly. Certain errors in running IHEAT 
v4.0 can be anticipated as users become acquainted with the 4.0 version of the software. Software 
best practice guidelines are outlined below to help new users avoid known pitfalls. 

 
1. The user must ensure the location of the LUT in the set-up file for the current run is correct on 

the local system. If the set-up file contains a path to a LUT .dat file that is stored in another 
user’s directory, the software may not have permission to access that file to compute 
temperatures in the IHEAT v4.0 images.  
 

2. The user must make sure the LUT path points to a .dat version of a LUT, rather than the 
obsolete .lut file type from the legacy 3.2 version of IHEAT. If data from a test conducted prior 
to 2015 must be re-reduced in IHEAT v4.0, the .lut file for the LUT first must be converted to 
a .dat file that can be read into IHEAT v4.0.  All of the existing LUT files that were formatted 
for IHEAT v3.2 have been converted to a format that is usable in IHEAT v4.0 using a separate 
script. To obtain one of these converted files, consult the authors of this report. 
 

3. The user should be careful not to use the Load LUT tool to apply a LUT to a temperature image 
that differs from the LUT specified in the set-up file for that run. Only the LUT that corresponds 
to the acquired phosphor thermography data should be used in the quantitative data reduction. 
The reason the Load LUT tool exists is to simplify the process to check new LUTs when 
calibrations are performed for new batches of the phosphor mix. 
 

4. The user cannot exit an Auto Profile operation while setting fiducial marks without causing an 
error (unless the reference line and the two initial x and y fiducial mark values are already 
defined). For now, this problem is addressed by printing a warning message when the user 
begins defining the reference line and the fiducial marks. If the user exits the Auto Profile tool 
prematurely, he or she will encounter an error and will have to restart the IHEAT v4.0 software 
to complete an Auto Profile analysis. 
 

5. The user may encounter errors in the Auto Profile tool if fiducials that are in close proximity 
to each other and are assigned similar x/L or y/yref values are not carefully defined. If line cuts 
in the grid are either left out or drawn incorrectly when these similar fiducial marks are defined, 
either (1) use fewer or different fiducial marks in the analysis to avoid using the similar marks, 
or (2) move one of the fiducial marks one or two pixels away from the previously defined 
location to make sure the grid is defined correctly. 
 

6. The user must remember to click New Batch prior to conducting a Batch operation to make 
sure enough memory is available to compute and to save all of the data for the images in the 
run folder. More memory is available on the server than on many personal computers, but 
conducting Batch operations in folders with at least 100 run images can quickly overwhelm 
any system if the memory is not cleared periodically. 
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7. The user must confirm that the correct flow conditions, position gauge, and image files are 
copied to the run folder prior to performing a Load Run or a Batch operation. If the wrong 
.tekflw or .tif files are in the folder, an error will occur during the process of matching up those 
files when either the Load Run or the Batch operation are attempted. 
 

8. The user should not rename run or prerun temperature image files or change the extensions on 
the set-up (.ihs), flow conditions (.tekflw), or position gauge (.tektxt) files to ensure that the 
automated algorithm in the Batch process functions correctly. Additionally, the naming 
convention for the image files is case sensitive. 

 
9. Prior to a Batch operation, the user should ensure that no additional .tif images are stored in 

the run folder aside from the run and prerun temperature images. Other .tif files can be stored 
to the folder as needed if the Batch operation is not required, but the automated process for 
finding run and prerun temperature images will not function properly if additional .tif files are 
stored in the same run folder prior to using the Batch tool. 
 

10. The Batch operation takes a lot of memory and is operated within the compiler runtime module 
and should not be interrupted. The user should be careful not to click on other tools within 
IHEAT while a Batch process is running. A separate instance of IHEAT can be opened while a 
Batch operation is conducted, but the user should exercise caution to avoid exceeding the 
available memory on the system. 
 

11. The user should not open “combined” line cut files generated via a Batch process before the 
Batch operation has been completed. Opening these files prematurely can cause errors as the 
software tries to access the open file to append additional information to the files. 
 

12. The user must exercise caution when implementing the Convert Files tools, since the files in 
the selected directory will be overwritten with the reformatted files. 
 

13. The user should not use the Export Cursor Data to Workspace option associated with the 
MATLAB® built-in data cursor tool since that option does not work correctly in the stand-alone 
executable IHEAT v4.0 software. 
 

14. If certain toXols are opened, such as Length, Profile, Piecewise, Mask, Data, or Statistics, the 
user must place the appropriate object (such as a rectangle in the Mask tool or a line in the 
Profile tool) in the image window prior to exiting the tool. Otherwise, IHEAT v4.0 will 
malfunction. The reason for this error is the software expects user input to generate the object 
once the tool is entered, so IHEAT v4.0 waits for the user input even after the tool is exited. 

 
15. The user should not change the run folder while the Length, Profile, Piecewise, or Print Data 

tools are running. These tools use while loops to continuously update the positions of the lines 
or data points required in each case. The Run Folder variable is not saved properly when the 
user changes this string during the while loop. In future iterations of IHEAT v4.0, this variable 
will be disabled when those tools are accessed.  
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16. The user should not continue to use the same instance of IHEAT v4.0 after an error occurs. 
Instead, the user should save any processed data, then restart the software. Errors in the 
software sometimes compound and create problems that would not occur if the first error was 
not in memory. 
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IHEAT v4.0 will be upgraded to include additional features that are currently under 
development or in the beta stage of testing. One tool that is in the beta-testing stage is the three-
dimensional (3D) mapping tool. An extrapolation-to-flight module also has been added to IHEAT 
v4.0, but this tool is only in the alpha testing phase. Another planned module will compute heating 
data from infrared radiation (IR) temperature data. Addendums to this report will explain how to 
use the debugged versions of new IHEAT tools to reduce aeroheating data obtained via phosphor 
thermography or IR. 
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